当前位置: 首页 > >

Android同时使用多个library时的问题

发布时间:

剧情是这样,我的app要使用四个library,如:LibraryA,LibraryB。这两个库又都需要support.v4.jar。


由于加载的时间不同,所以四个support.v4.jar不同,出错的提示如下:


Found 5 versions of android-support-v4.jar in the dependency list,
but not all the versions are identical (check is based on SHA-1 only at this time).
All versions of the libraries must be the same at this time.Versions found are:


从提示中可以知道,这五个support-v4.jar不同,所以会发生冲突,


解决方法:把所有libs中的support-v4.jar文件统一,然后刷新这个包,让他重新生成,然后就OK了



友情链接: